Mozilla Patches Critical Vulnerabilities in Firefox, Firefox ESR

The Cybersecurity and Infrastructure Security Agency (CISA) encourages users and administrators to review Mozilla’s security advisory for Firefox 74.0.1 and Firefox ESR 68.6.1 and apply the necessary updates.

You can read the full article here.