PostgreSQL Database Password Change Stack Buffer Overflow (CVE-2019-10164)

A stack buffer overflow exists in PostgreSQL Database. The vulnerability is due to a stack buffer overflow when setting a password. A remote, authenticated attacker could send a crafted request in order to trigger the vulnerability. Successful exploitation will result in arbitrary code execution.

You can read the full article here.